[chiplotle-discuss] HP ColorPro Plotter supported?

douglas repetto douglas at music.columbia.edu
Tue Jan 3 22:51:25 EST 2012


Is /dev/ttyS0 really your serial port? What sort of usb<->serial adapter 
are you using, and on what platform? That's an odd name for a serial 
adapter, so my first guess is that there's something wrong with your 
basic serial adapter setup. Maybe you need to install a driver?

best,
douglas

On 1/3/12 10:44 PM, Anthony Fink wrote:
> Hey there, I'm trying to get Chiplotle going with my HP ColorPro
> plotter. This plotter was one of the only HP plotters not given an
> official designation number, but it's informally known as the HP 7440.
> Right now I can't get Chiplotle to recognize it properly. I know it's
> completely HPGL compatible and should just use the regular command set
> as well as the HP graphics extensions for curves etc. I also have the
> complete user manual with proper dipswitch and cabling diagrams, and
> have made sure my baud rate, parity, bits (this plotter uses 7, not 8) ,
> etc. all match and my cable is wired correctly. Any ideas?
>
> Just FYI, the output from Chiplotle under my current setup looks like this:
>
>
>    +-----------------------+
>    |   Chiplotle! v.0.3.1  |
>    +-----------------------+
>
> Scanning serial ports...
> Found ports:
>    /dev/ttyS0
>
> Sniffing for plotters in all serial ports...
> Traceback (most recent call last):
>    File "<string>", line 1, in <module>
>    File
> "/usr/local/lib/python2.7/dist-packages/Chiplotle-0.3.1-py2.7.egg/chiplotle/tools/plottertools/instantiate_plotters.py",
> line 20, in instantiate_plotters
>      result = search_and_instantiate_plotters( )
>    File
> "/usr/local/lib/python2.7/dist-packages/Chiplotle-0.3.1-py2.7.egg/chiplotle/tools/plottertools/search_and_instantiate_plotters.py",
> line 25, in search_and_instantiate_plotters
>      plotters_found = sniff_ports_for_plotters(ports)
>    File
> "/usr/local/lib/python2.7/dist-packages/Chiplotle-0.3.1-py2.7.egg/chiplotle/tools/serialtools/sniff_ports_for_plotters.py",
> line 11, in sniff_ports_for_plotters
>      plotter_name = what_plotter_in_port(port)
>    File
> "/usr/local/lib/python2.7/dist-packages/Chiplotle-0.3.1-py2.7.egg/chiplotle/tools/serialtools/what_plotter_in_port.py",
> line 29, in what_plotter_in_port
>      id = ser.readline(eol='\r').strip('\r')
> TypeError: readline() takes no keyword arguments
> chiplotle>
>
> Thanks in advance for your help.
> -Tony Fink
>
>
> _______________________________________________
> chiplotle-discuss mailing list
> chiplotle-discuss at music.columbia.edu
> http://music.columbia.edu/mailman/listinfo/chiplotle-discuss

-- 
............................................... http://artbots.org
.....douglas.....irving........................ http://dorkbot.org
.......................... http://music.columbia.edu/cmc/music-dsp
...........repetto............. http://music.columbia.edu/organism
............................... http://music.columbia.edu/~douglas



More information about the chiplotle-discuss mailing list