[chiplotle-discuss] initial winXP Pyserial & readline woes etc...

Ryan Gallagher clickykbd at gmail.com
Thu Mar 1 21:55:53 EST 2012


Up and running with chiplotle, but I ran into that pyserial readline
expected arguments difference, eventually got around it with python27,
chiplotle0.3.2, and pyserial2.5 on windowsXP.

Then I tried to do an example virtual plot, and an instance of
readline expected the reverse it seems.  Can't have both?  Is virtual
plotting even known to work on windows?  Does switching to the trunk
fix this?  Or know the pyserial version which is happiest?   Is the
DXY-1100 also a known plotter in the trunk, or is it considered
identical to the DXY-1300?

I also had some initial configuration frustration about where
chiplotle looks for my home directory, which seems to change depending
on which drive letter I am running chiplotle from, have chiplotle dirs
in two places now as a quick fix.  (I have my profiles stored on a
different windows partition.)

Another mild non-chiplotle curiosity, my Roland windows drivers are
happy on parallel, but very unhappy over usb-serial (despite chiplotle
seeming perfectly content).  It plots but doesn't pick the pen up when
it should, crazy ordering, and some random lines not in the plot...
eventually leading to flashing error.  Any thoughts?  Was hoping to
avoid having to switch cables and dip switches constantly.

Maybe I should set up chiplote on my netbook and forget about fighting
with windows except when I need autocad to draw something.  ;-)

-- 
ryan
clickykbd at gmail.com

"The most beautiful thing we can experience is the mysterious. It is
the source of all true art and science."
---Albert Einstein


More information about the chiplotle-discuss mailing list