[jsyn] parts is parts
philburk at s...
Thu Mar 7 11:10:58 EST 2002
Yes, using both the names inputA and input0 would be confusing. But I am
still inclined to use input0 for the new LineOut inputs. And I cannot get
rid of inputA on AddUnit because it would break existing code. So tell me if
this naming scheme makes any sense.
An AddUnit represents a binary operator that implements Y=A+B. So the names
are inputA and inputB.
A LineOut represents a multi-channel output device that correspond to
channels, which are normally indexed. So the names would be input0 and
input1. Also they derive from the old multi-part input which was indexed.
From: "Bradford Garton" <garton at c...>
> Ditto for me (a port array makes sense), but the main thing is consistency
> with whatever scheme. I recall being confused about when things were
> "inputA" or "0" in terms of addressing. Input (and output!) naming
> consistency would make me happy happy happy.
More information about the JSyn