[Alsa-devel] Re: [linux-audio-dev] snd-hdsp oddities

Takashi Iwai tiwai at suse.de
Fri Jul 2 09:15:46 EDT 2004


At Fri, 2 Jul 2004 12:56:06 +0000,
<ico at fuse.net> wrote:
> 
> > Shouting "DON'T USE 2.6" isn't a good solution.  Though, we need to
> > inform to "set LD_ASSUME_KERNEL as a workaround"...
> 
> Pardon my ignorance but how does one do this? As a part of the
> config before compiling kernel or? 

No, just set the environment variable like
	export LD_ASSUME_KERNEL=2.4.19
(better globally) and start jack.  That's all.

In this way, glibc chooses LinuxThreads instead of NPTL.

> Also, any ideas on the odd behavior of the hdspmixer? (see my other post)

Not checked yet...  Did hdspmixer work on any versions correctly on
your system?


Takashi


More information about the linux-audio-dev mailing list