[linux-audio-dev] Freeverb and default control parameters

mathias_lundgren at bredband.net mathias_lundgren at bredband.net
Tue Nov 23 17:36:53 EST 2004


> 
> From: Dave Robillard <drobilla at connect.carleton.ca>
> Date: 2004/11/23 ti AM 07:58:55 GMT
> To: "The Linux Audio Developers' Mailing List"
> 	<linux-audio-dev at music.columbia.edu>
> Ämne: Re: [linux-audio-dev] Freeverb and default control parameters
> 
> On Sun, 2004-21-11 at 19:50 +0100, Mathias Lundgren wrote:
> > sön 2004-11-21 klockan 17.26 skrev Dave Robillard:
> > > On Sun, 2004-21-11 at 15:21 +0100, Mathias Lundgren wrote:
> > > > Hi!
> > > > 
> > > > I've been trying to implement LADSPA send effects in my latest playtoy.
> > > > I've had some problems with freeverb though. It simple doesn't produce
> > > > any output (execution seems to be veeery demanding) until I specifically
> > > > set some of the parameters to non-default values. I thought the default
> > > > port parameters would take care of this, initializing the plugin with
> > > > sane values to avoid things like these, but perhaps I'm doing something
> > > > wrong... Has anyone else noticed anything similar with freeverb?
> > > > 
> > > > /Mathias
> > > > 
> > > 
> > > Are you specifically setting the default values?  They're just hints,
> > > the host still has to set them.  Plugins don't initialize ports to
> > > default values IIRC, they will be garbage until you set them to
> > > something.
> > > 
> > > 
> > > -DR-
> > 
> > Yes, I'm specifically setting them, with the values provided by the
> > hinst. Using the hint-values, nothing comes out of it and execution is
> > really slow, when using some "personal" values, things mysteriously
> > begin to work.
> > 
> > /Mathias
> > 
> > 
> 
> Looks like the default values for freeverb have both dry and wet gain at
> 0.  That would explain it, eh? :)
> 
> -DR-
> 

I guess it might have something to do with the whole thing. And I don't have a problem with a plugin producing no "pluginnish output" when it's launched, using the default values, but... Even though they're merely 
hints, the freeverb init-settings (yeah okay, they're not init-settings, but "hints") really aren't nice to the system, and I don't like that.

/Mathias




More information about the linux-audio-dev mailing list