[linux-audio-dev] Re: Trying to build Om,

Stephen Cameron smcameron at yahoo.com
Thu Jul 6 23:20:44 EDT 2006



--- Loki Davison <loki.davison at gmail.com> wrote:

> On 7/6/06, Stephen Cameron <smcameron at yahoo.com> wrote:
> > --- Dave Robillard <drobilla at connect.carleton.ca> wrote:
> >
> > > On Wed, 2006-07-05 at 20:41 -0700, Stephen Cameron wrote:
> > > >
> > > > --- Loki Davison <loki.davison at gmail.com> wrote:
> > > >
> > > > > On 7/6/06, Stephen Cameron <smcameron at yahoo.com> wrote:
> > > > > > > --- Stephen Cameron <smcameron at yahoo.com> wrote:
> > > > > > > > So, I'm trying to build Smack, which needs Om, which needs
> > > > > > libgnomecanvasmm,
> > > > > > > > which my os (Fedora Core 3) doesn't seem to have, so I found it
> > here:
> > [...]
> > > > I tried to start om_gtk... First it complained about not being able to
> > find
> > > > libgnomecanvasmm.2.6.so.1, so, try (in /usr/lib)
> > > >
> > > > ln -s libgnomecanvasmm-2.6.so.1.0.1 libgnomecanvasmm-2.6.so.1
> > > >
> > > > Now, it complains...
> > > >
> > > > [scameron at zuul ~]$ om_gtk
> > > > [StateManager] Unable to open settings file /home/scameron/.omgtkrc
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `focus_on_map' for
> > class
> > > `gtkmm__GtkWindow'
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `ellipsize' for
> > class `gtkmm__GtkLabel'
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `width_chars' for
> > class `gtkmm__GtkLabel'
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `single_line_mode'
> > for class
> > > > `gtkmm__GtkLabel'
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `angle' for class
> > `gtkmm__GtkLabel'
> > > > (om_gtk:2173): libglade-WARNING **: unknown property `ellipsize' for
> > class `gtkmm__GtkLabel'
> > > >
> > > > And finally, it dies with a bunch of crap like this:
> > > >
> > > > ** (om_gtk:2173): CRITICAL **: Gnome::Glade::Xml::get_widget():
> > dynamic_cast<> failed.
> > > >
> > > > So I guess I don't yet have the right libgnomecanvasmm,
> > > > or libglade*so* or something for Fedora Core 3...
> > >
> > > Looks like your GTK/GTKmm version is too old.  (Actually since you're
> > > using FC3, I'd bet the farm on it.  A while back some crazy idiot
> > > complained about my dependency on a Gtk version that'd been out as a
> > > stable release for almost 2 years because Fedora was so on the
> > > ball... :) )
> > >
> > > The configure script should have stopped you from building it though,
> > > odd.  What version of gtkmm?
> > >
> > > -DR-
> > >
> > >
> > [scameron at zuul software]$ rpm -qa | grep gtkmm
> > gtkmm24-2.4.11-1
> > gtkmm24-devel-2.4.11-1
> > gtkmm24-docs-2.4.11-1
> >
> > And just to check in case I built it from source without telling RPM...
> >
> > [scameron at zuul software]$ ls -ld /usr/lib/libgtkmm*
> > -rw-r--r--  1 root root 4127910 May 11  2005 /usr/lib/libgtkmm-2.4.a
> > lrwxrwxrwx  1 root root      22 Jun 17 12:14 /usr/lib/libgtkmm-2.4.so ->
> > libgtkmm-2.4.so.1.0.11
> > lrwxrwxrwx  1 root root      22 Jun 17 12:14 /usr/lib/libgtkmm-2.4.so.1 ->
> > libgtkmm-2.4.so.1.0.11
> > -rwxr-xr-x  1 root root 2517840 May 11  2005 /usr/lib/libgtkmm-2.4.so.1.0.11
> > [scameron at zuul software]$
> >
> > Hmm, looking at gtk.org, I see gtk and friends churn quite a lot.
> > I foresee hours and hours of downloading in my future.
> >
> > Should I grab gtk 2.8 + dependencies?
> >
> > -- steve
> 
> It doesn't take that long to build it all from source, it might be
> easier to do some kind of upgrade/update/distupdate of your distro
> instead. Can you just change where your apt-get/whatever sources are
> pointed at and then upgrade easily. I've done this many times over
> many years with mandriva and never had a problem.
> 
> Loki
> 

Actually, I already built it from source this morning, but, still no go...

All these from gtk.org:

    * Installed cairo-1.2.0
    * Installed glib-2.6.6 ... it went into /usr/local/lib
    * set LD_LIBRARY_PATH, PKG_CONFIG_PATH to include /usr/local/lib...
    * Installed atk-1.9.0
    * Installed pango-1.8.2
    * Installed gtk-2.6.10 

Reconfigured om... noticed it complained about lash not being found...

    * Installed lash-0.5.1 from http://www.nongnu.org/lash/ 

Reconfigured om-, and recompiled and installed. 
Still complains about the glade stuff as before.

I didn't rebuild libgnomecanvasmm though, because there
seems to be some compiler problem, it seems.

Maybe I have to upgrade gcc?

I have:
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)

Maybe I can't have those libs in /usr/local/lib, but must
have them in /usr/lib?

-- steve


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


More information about the linux-audio-dev mailing list