[linux-audio-user] The trouble with disks

John Anderson ardour at semiosix.com
Fri Dec 19 13:33:13 EST 2003


On Fri, 2003-12-19 at 19:28, Mark Knecht wrote:
> >
> > Yip, 0 overruns on all tests at 2x128.
> >
> > Real headscratcher, innit?
> >
> > bye
> > John
> >
> 
> Very perplexing. I've gone back and reread the whole thread. It certainly
> seems like you've done all the basics and then much more to debug this. I
> doubt anything I write here is actually the root cause and solution, but we
> might as well keep trying.

Thanks

> A few questions did come up for me while reading:
> 
> 1) When you say '0 overruns' above, how did you determine this? I found when
> running this test that I'd sometimes get these 'blips' in the scheduling
> time that would come close to the breakpoint, but not actually go over. Do
> you see anything like that?

Yeah, there was a pretty regular series of spikes in white. None of them
were closer than, say 10-15% of the total distance.

> 2) You said you tried tmpfs. What version of Jack are you using, and did you
> recompile Jack to do that test?

0.91.3, I've been updating from CVS every few days since about 3 weeks
ago. That was just before 0.90 IIRC.

> 3) How are you starting Jack? In a terminal or using qjackctl. I have not
> reported this before, but I seem to see more xruns when using qjackctl than
> when running Jack in a terminal with the same settings.

> 4) What command are you generally using to start Jack?

In a terminal. jackd -R -d alsa -d hw:0 -p 256 -n 3

> 5) Since APIC is not necessary on a uni-processor, have you tried disabling
> it at boot time?

I tried removing the option and recompiling the kernel when I was
messing around with IRQ priorities. Didn't seem to make much of a
difference so I put it back to APIC and left it there.

> 6) Possibly important. You said you had a dual-processor up until a few
> weeks ago. I presume that you were using the same sound card in that system?
> (Thus eliminating the sound card itself as the culprit.) Were you using the
> same hard drive?

Same hard drive, same SCSI controller, same sound card. Only difference
from that point of view is that the SCSI controller used to be in a
64bit PCI slot. But I can't see that making a huge difference because
the throughput from one drive wouldn't even begin to get close to the
throughput limits of a 32 bit slot. Well, I'm guessing here.

> 7) Have you tried looking at this problem with sessions recorded at
> different sample rates? In a conversation with another user the other day he
> was telling me he gets more xruns at 44.1K than 48K.

Only at 48k - that's all I've got.

bye
John




More information about the linux-audio-user mailing list