[linux-audio-user] Re:UPDATE insmod errors - rme hammerfall multiface UPDATE

Fernando Pablo Lopez-Lezcano nando at ccrma.Stanford.EDU
Wed Feb 4 18:35:15 EST 2004


> > here are some revised details of my problem!
> > 
> > i am actually running the planetccrma kernel 2.4.20-18.1.caps
> > 
> > [MUNCH]
>
> Could you please check the alsa version used by your running kernel (cat 
> /proc/asound/version) ? I suspect that you still have an old alsa 
> version, because the hammerfall_mem module is no more used to allocate 
> the buffer's memory. I you happen to have an old version of alsa, it is 
> probable that your card revision (0x32) was not supported at the time. 
> Updating to alsa 1.0.2 should solve the problem.

Thanks Thomas, I was reading but somehow things were not going "click"
in my mind (not that they do that very often :-)

Rob: if you are running 2.4.20-18.1.caps then your alsa kernel module
package (from Planet CCRMA) are pretty old and probably do not support
your card, as Thomas pointed out. Maybe you have newer ALSA packages (I
remember you saying something about 1.0.2?) but they probably don't have
kernel modules for the Planet CCRMA kernel, you must have gotten them
somewhere else - the latest Planet CCRMA ALSA is 1.0.1. 

To get the latest ALSA from Planet CCRMA you should install the
2.4.20-28.1.caps kernel and associated ALSA packages... make sure you
have the planetcore repository in your /etc/apt/sources.list, "apt-get
update", "apt-get install planetccrma-core-redhat". 

-- Fernando




More information about the linux-audio-user mailing list