[linux-audio-user] pd -jack alsa - pd crash needs reboot

rob canning rscanning at eircom.net
Thu Feb 12 12:36:35 EST 2004


Hi,

i am running pd 0.37.0 as root with the latest kernel from planetccrma with -jack using Qjackctl as user - i am using alsa 1.0.1 with a hdsp card on RH.9  P4 2.6 with 2gigs of dual channel ram

jackstart -R -d alsa -d hw:0 -r 44100 -p 1024 & (or somthing like that)

pd -rt -jack

whenever i use the plugin~ 0.2 (LADSPA) external, the smallest thing (select all- drag) causes pd to crash and the only way it will restart is by doing a reboot.

i just tried without plugin~ and get the same thing though plugin~ does seem to like to crash my system quite easily..

here is the last jack error: 

subgraph starting at pure_data_0 timed out (subgraph_wait_fd=24, status = 0, state = Running)
client pure_data_0 error: awake_at = 663526372 state = 2 timed_out = 2
**** alsa_pcm: xrun of at least 11.868 msecs
13:32:56.712 Audio connection graph change.
13:32:56.712 XRUN callback. (4)
13:32:56.837 Audio active patchbay scan...

i can't restart pd with either -jack (with the jack server running) or -alsa (with the jack server off) unless i reboot

sometimes i get the audio in/out stuck - closing error sometimes but mostly the watchdog: signaling pd error just keeps appearing

any ideas?

or, if not, is there anyway i can reinitiate things without having to do a reboot?

thanks,

rob
www.robcanning.utvinternet.com



More information about the linux-audio-user mailing list