[linux-audio-user] MIDI + Audio

cv223 at comcast.net cv223 at comcast.net
Thu Feb 26 22:26:16 EST 2004


Hi,

I'm trying to set up my Linux system for a number of audio projects.  My first idea was to tap into the wealth of audio tools available to help me practice.  The basic idea is to generate a MIDI file of a tune using one of a number of programs (mma, gmorgan, pymprovisator, etc.), play the midi file through a sequencer like MusE or Rosegarden while recording my audio part (I play bass) for later post-mortem analysis.  This seemingly simple task has me stymied.  I have jackd (via qjackctl) and fluidsynth (via qsynth) running ok, but I have two completely different problems with MusE and Rosegarden:

1) MusE 0.6.2: Audio input seems to work (audio mixer in MusE shows signal), but there is no sound when MIDI plays back.  I've turned up every fader I can find and still no MIDI output.  The little "jumping bars" on each MIDI track indicate that _something_ should be happening.  I don't get sound from the built-in softsynths, either. I must be missing something simple! A mute button? A master gain control?? The fluidsynth MIDI part of the signal chain seems fine, because of 2), below. I was previously working with MusE 0.6.0, which gave MIDI output after a bit of fussing - maybe I should go back to it?

2) Rosegarden4 0.9.6: MIDI output works fine, but I get no audio input (the audio input indicator doesn't show anything, and recording shows silence).  The audio part of the signal chain seems to be working because of 1), above, plus I can record audio with Ardour ok.  I was previously trying version 0.9 where the audio recording worked, but there was a huge delay between the MIDI and audio tracks.  Info I saw on the Rosegarden users email list seemed to indicate that 0.9.6 should fix a problem with MIDI recording delay, so I figured it would do something about the audio delay.

In both situations, jackd connections are what I would expect (e.g., with Rosegarden, qjackctl shows an audio input connection to Rosegarden).

If anyone has any ideas, I would _greatly_ appreciate suggestions.

BTW, I'm running a Gentoo system with the latest ebuilds for these programs, if that helps.

Thanks,

Joel

PS Double thanks to everyone who has contributed to all the cool Linux audio apps!


More information about the linux-audio-user mailing list