[linux-audio-user] Re: Stuttering via HDSP, Cardbus, Multiface?

derek holzer derek at x-i.net
Fri Mar 26 16:44:01 EST 2004


Tim Blechmann wrote:

> ricoh ??? (derek / gentoo)

CardBus bridge: Ricoh Co Ltd RL5c476 II (rev a8)


> - derek: what problems exactly did you have? i'm not exactly sure, if
>   your problem was similar to the one, ico, timothy and myself are
>   experiencing ... 

I ran the spectrum of problems, but them main issue was that the card 
would not make sound. Sometimes the card was not recognized, sometimes 
the card was recognized, but the firmware would not load. Other times, 
card was recognized, firmware was loaded, but I would get awful sound 
out of it like the problems you, Timothy and Ico report. But that was 
the last step along the way, and I could attribute it to bad IRQ 
assignment from ACPI, if I remember correct. But that only happened 
after a significant amount of "voodoo" with the recognition and the 
firmware with Planet-CCRMA.

By "voodoo", I mean things like this: there were times, espc with Red 
Hat, where it seemed to work only after power cycling both the laptop 
and the multiface, but that was not a real solution. Changing distros 
was the final voodoo, but it seemed to do the trick. You can search the 
archives of Planet-CCRMA list for "derek+HDSP" for all the gorey details 
of my saga there, as I kept them very up to date on my woes.

> - ene, o2micro and ricoh are cardbus bridges, rme doesn't suggest for
>   using with an hdsp ... but they haven't had any complains about ti's
>   cardbus bridges...

TCI 1420 and 1440 are listed as problem cards by RME. TCI 1225 shows up 
ok, though, so I imagine a 1250 is probably cool too. I maintain to this 
day it is something between the cardbus controllers, their 
kernel-drivers or modules, or the configurations thereof which creates 
this mess. I don't think the ALSA-dev folks have much power to correct 
this problem, although I would bet that their understanding of the 
upstream problems might be more educated than ours. My guess, along with 
Ico, is that kernel-dev folks might be the best resource, if you can 
document the issue well enough. Which is hard when you aren't sure 
excatly where it lies.

good luck,
D.


-- 
derek holzer ::: http://www.umatic.nl
---Oblique Strategy # 196:
"What else is this like?"


More information about the linux-audio-user mailing list