[linux-audio-user] VSTserver on MDK 10.0

Russell Hanaghan hanaghan at starband.net
Fri May 7 14:56:20 EDT 2004


On Fri, 2004-05-07 at 11:39, James Stone wrote:
> On Thu, May 06, 2004 at 04:46:29PM -0700, Russell Hanaghan wrote:
> > On Thu, 2004-05-06 at 16:11, Russell Hanaghan wrote:
> > > On Thu, 2004-05-06 at 15:49, James Stone wrote:
> > > > On Thu, May 06, 2004 at 02:18:56PM -0700, Russell Hanaghan wrote:
> > > > > On Thu, 2004-05-06 at 08:11, Russell Hanaghan wrote:
> > > > > > Has anyone got Thacs vstserver and libvst working on mandrake?
> > > > > > 
> > > > > > I have tried and tried to no avail. Wine is running and seems to fire up
> > > > > > the standard stuff like filemanager, windblows games, etc.
> > > > > > 
> > > > > > I suspect it's to do with libvst but don't know.
> > > > > > 
> > > > > > I'd really like to get this working as I have many vst plugins.
> > > > > > 
> > > > > > thanks
> > > > > > 
> > > > > > 
> > > > > > R~
> > > > > > 
> > > > > 
> > > > > OK...I"M GOING TO KILL MYSELF~ Bloody great folder full of VST's and I
> > > > > can't get the &&^%*((*) to work. (And that's NOT code I'm expressing) :P
> > > > > 
> > > > > I have uninstalled, reinstalled, added vst.so to every folder to every
> > > > > server on the internet, I sat the box on its end and worshipped it...I
> > > > > spread the blood of a freshly beheaded goat in a circle and chanted to
> > > > > the great god of VST!!! WiNE is making me Whine!!  Someone somewhere
> > > > > must know where all the bits and pieces should go to make this work!
> > > > > Does NOBODY love me anymore??  I like whales...I dont pick the wings
> > > > > from butterflies. I even call mummy dearest on mum's day! 
> > > > > 
> > > > > WINE is not whining...it works! I think its vstserver and some
> > > > > dependency thingy...or maybee I should use a pig instead of a goat??
> > > > > 
> > > > > Please...I'm offering camels and small children! Take my wife, take mah
> > > > > truck, take my stuff....just make it work, please, please, please,
> > > > > please!!!
> > > > > 
> > > > > Whew!  Grovelling is NOT in my nature....ergo...this is serious. 
> > > > > <insert fav. smiley wrinkly face here>
> > > > 
> > > > I don't know about Mandrake (any more..) and I don't know about the rpms
> > > > of vstserver. What I would recommend is you uninstall wine, download the
> > > > version of wine for vstserver (0.3.0), build that, build vstserver
> > > > (after adding your vst path variable), then vsti (and prolly the k_vst~
> > > > pd plugin which has much more functionality).
> > > > 
> > > > I am sure it will work fine. It did for me (eventually!).
> > > 
> > > Aww man...Every time I try to build stuff it doesnt work! Says stuff
> > > like...We don't like your haircut....so we can't find the files or
> > > directory you need! 
> > 
> > Ran ./tools/wineinstall. Got thru a hundred pages of compiling to tell
> > me "-pthread Unknown option. Aborting install.
> > 
> > Trying other package
> >
> 
> And this was with the wine version in vstserver-0.3.0-wine.tar.bz2 ?
> 
> Builds fine on my Debian box, but then I remember vaguely now that when
> I was running Mandrake, building by hand did not work very well.

Except for small stuff, NOTHING ever builds properly for me on MDK.

> 
> What RPMs are you using? Have you defined the vstpath?

Yessir!  Using Thac's RPMs which are always pretty good.

export VST_PATH=/usr/share/VST

R~

> 
> James
> 



More information about the linux-audio-user mailing list