[linux-audio-user] xmms-jack 'couldn't open audio' problem

Jussi Sainio jusic at epoksi.afraid.org
Sun Oct 17 16:27:02 EDT 2004


Hi,

I have this problem when using xmms-jack output plugin in xmms..

If I run it as a normal user, I get usually "Couldn't open audio..." error box,
but when running as root it works without problem. Could this be a
permission issue or something?

jack-rack, alsaplayer and ams don't have this kind of problem at all.


jackd runs in realtime -mode, kernel is 2.6.9-rc2-mm4-VP-S7
xmms 1.2.10, xmms-jack 0.10 (0.9 has same issue, tested it too..)

Here is some debugging output:

xmms (xmms-jack verbose and trace mode enabled):

[...]
JACK_GetVolumeForChannel:deviceID(0), returning volume of 25 for channel 0
JACK_GetVolumeForChannel:deviceID(0), returning volume of 25 for channel 1
JACK_OpenEx:bits_per_channel=16 rate=44100, input_channels=2,
output_channels=2
JACK_OpenEx:jack_port_name = NULL
JACK_ResetFromThis:resetting this->deviceID(0)
JACK_OpenEx:bytes_per_output_frame == 4
JACK_OpenEx:bytes_per_input_frame  == 4
JACK_OpenDevice:creating jack client and setting up callbacks
JACK_OpenDevice:client name 'bio2jack_0_7504'
JACK_OpenDevice:setting up jack callbacks
JACK_srate:the sample rate is now 48000/sec
JACK_OpenDevice:engine sample rate: 48000
JACK_OpenDevice:creating output ports
JACK_OpenDevice:port 0 is named 'out_0'
JACK_OpenDevice:port 1 is named 'out_1'
JACK_bufsize:the maximum buffer size is now 256 frames
JACK_bufsize:expanding buffer from this->buffer_size == 0, to 1024
JACK_bufsize:called
JACK_OpenDevice:calling jack_activate()
ERR: JACK_OpenDevice:cannot activate client
JACK_OpenEx:error opening jack device
JACK_GetVolumeForChannel:deviceID(0), returning volume of 25 for channel 0
JACK_GetVolumeForChannel:deviceID(0), returning volume of 25 for channel 1


jackd verbose mode:

[...]
load = 0.3697 max usecs: 13.000, spare = 5320.000
new client: bio2jack_0_7504, id = 3 type 2 @ 0xb6555000 fd = 20
23:07:43.989 Audio connection graph change.
registered port bio2jack_0_7504:out_0, offset = 3072
registered port bio2jack_0_7504:out_1, offset = 4096
gave capabilities to process 7504
23:07:44.152 Audio connection change.
load = 0.3818 max usecs: 21.000, spare = 5312.000


Any help would be appreciated. :)

Thanks.

--jussi


More information about the linux-audio-user mailing list