[linux-audio-user] xrun madness

Mark Knecht markknecht at gmail.com
Wed Oct 20 00:07:15 EDT 2004


On Tue, 19 Oct 2004 22:54:56 -0400, Joel White <cv223 at comcast.net> wrote:
> Hi,
> 
> Joel Roth suggested "simplifying" my xrun problem by recording with
> ecasound and see if I get xruns (rather than with jackd and ardour -
> thanks, Joel!).  I've built ecasound and am trying to get a simple
> multitrack recording happening, while monitoring at the same time.  I
> don't know much about ecasound, so here's what I've tried:
> 
> ecasound -r -b:256 -a:1,2,3,4,5,6,7,8 -f:16,8,48000 -i alsa,default \
> -a:1 -o mono-1.wav \
> -a:2 -o mono-2.wav -erc:2,1 \
> -a:3 -o mono-3.wav -erc:3,1 \
> -a:4 -o mono-4.wav -erc:4,1 \
> -a:5 -o mono-5.wav -erc:5,1 \
> -a:6 -o mono-6.wav -erc:6,1 \
> -a:7 -o mono-7.wav -erc:7,1 \
> -a:8 -o mono-8.wav -erc:8,1 \
> -a:all -o alsa,default
> 
> I can hear the inputs, but the mono-*.wav files are essentially empty
> (44 bytes each).  If I remove the last line, the mono-*.wav files record
> ok.  But, of course, I can't hear it while recording.  Can anybody tell
> me what I'm doing wrong (I suspect it is something about opening
> alsa,default twice, but I don't really know).
> 
> I want to get this working with ALSA (if possible), then try it jack.  I
> will then see what happens with xruns at each step of increasing
> "complexity."
> 
> Thanks!
> 
> Joel
> 
> 

It's been quite a while since I've heard of anyone using it, but what
about running Benno's disk latency testing program on your raid drives
and see what happens?

Or does that no longer work with 2.6 kernels?

When I worked with the tool it gave me very reasonable numbers vs.
what I was seeing for xruns.

Also, I don't think I remember you mentioning what desktop environment
you are using, but even with my 2.6.9-rc2-mm4 type kernel I got lots
of xruns under KDE, while Gnome was much better and fluxbox was, for
me, the best. (measurably...)


More information about the linux-audio-user mailing list