[linux-audio-user] Just bought a Delta 1010LT, now what..?

Glenn McCord clari_player at paradise.net.nz
Tue Sep 28 06:47:40 EDT 2004


Julien Claassen wrote:

>Hi!
>  I have a delta 1010lt, and had a lot of problems first. We couldn't really 
>solve them. We suspected that a slot was damaged and we just plugged it into 
>another slot, and from that day on my card runs perfectly. I think it is even 
>syharing its irq with my ethernet card. So if not tried already, do try to 
>change the slot. And another thing is: Don't use any alsa driver before 0.9.6 
>for your card. There was a bug - or more than one -, but this was mainly 
>solved in 0.9.6. But for good dshare, dmix and so on, better take 1.0.x 
>drivers.
>  Btw.: If you're looking for a nice .asoundrc for your card, when it's up and 
>running, drop a note.
>  
>

Yes please. That will come in very handy.

>  I hope that hleps in any way!
>  Kindest regards
>       Julien
>
>--------
>Music was my first love and it will be my last (John Miles)
>
>======== FIND MY WEB-PROJECT AT: ========
>http://ltsb.sourceforge.net - the Linux TextBased Studio guide
>
>
>  
>
I still have some niggling questions...

1. When I start the machine and try and run jackstart, it complains that 
the device in busy. I end up doing a # /etc/init.d/alsasound restart
in order to fix it.

2. I'm sure I used to be able to have jack running and be able to use 
other sound apps at the same time. i.e I could have jack running for 
ardour and then be able to use xmms at the same time. Instead I get this
glenn at upstairs glenn $ xmms

** WARNING **: alsa_setup_mixer(): Failed to find mixer element: PCM
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: 
Device or resource busy

** WARNING **: alsa_setup(): Failed to open pcm device (default): Device 
or resource busy

3. Trying to run fluidsynth will only work if I use it with alsa rather 
than through jack. It gives this error when I have xmms going

glenn at upstairs glenn $ fluidsynth -a alsa -m alsa_seq 
/usr/share/sfbank/4gmgsmt.sf2
fluidsynth: warning: Failed to pin the sample data to RAM; swapping is 
possible.
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: 
Device or resource busy
fluidsynth: error: The "default" audio device is used by another application
Failed to create the audio driver

As a side note. fluidsyth seems to totally butcher the midi. Even with 
the same soundfont, fluidsyth never sounds like it does with a 
soundblaster Live! using sfxload.

My 1010LT works, it's just a nuisance to have to tweak around all the 
discrepencies that are cropping up. I'm sure I must have had two sound 
apps running at the same time once before.

Thanks,
Glenn




More information about the linux-audio-user mailing list