[linux-audio-user] ld10k1 - success stories?

John Check j4strngs at bitless.net
Wed Feb 9 01:02:58 EST 2005


On Tuesday 08 February 2005 03:21 pm, Shayne O'Connor wrote:
> Mathias Lundgren wrote:
> >>>I'm not sure I saw a lot of documentation. I saw some doco for audigy in
> >>>ld10k1, I guess a lot is applicable on an sblive, but by reading that I
> >>
> >>The init_live script appears to have some naming issues FWIW.
> >
> >Yes, it seems so. I located it to the line that results in the following
> >output:
> >
> >/usr/local/bin/lo10k1 -n --ctrl "c-Left,Right:Wave Playback
> >Volume,t-Wave Playback Volume:1,c-LeftSurr,RightSurr:Wave Surro
> >und Playback Volume,t-Wave Surround Playback Volume:1,c-Center:Wave
> >Center Playback Volume,t-Wave Center Playback Volume:1,c
> >-LFE:Wave LFE Playback Volume,t-LFE Playback Volume:1" --patch_name
> >"Wave Multi Volume" -a simple.emu10k1
> >
> >Apparently c- has to do with "concatenating controls", not sure what it
> >means... simple.emu10k1 was loaded when I used this instead:
> >
> >lo10k1 -n --ctrl "" --patch_name "Wave Multi Volume" -a simple.emu10k1
> >
> >I guess it breaks things...
> >
> >>>can't really relate it to the gui. I've managed to load effects, but I
> >>
> >>I keep getting "not enough tram" or similar when I try to load FX.
> >>Can you clue me on what you did?
> >
> >I launched ld10k1 with -t 7, it says it initializes tram with 1024k.
> >Whatever that means...
>
> as far as i can remember, tram is the onboard memory for the emu10k1
> chip - different dsp effects take up different amounts of the cards
> memory, so you can't load up an unlimited number of effects ... i think
> the loading of soundfonts would also reduce the available tram size?
>
> shayne
j
j4strngs at araka:~$ asfxload -M
DRAM memory left = 131068 kB

I'll have to check once I get some FX loaded


More information about the linux-audio-user mailing list