[linux-audio-user] audacity jack

Andrew Gaydenko a at gaydenko.com
Thu Jul 7 17:12:19 EDT 2005


I have noticed, Audacity's CVS lib-src dir has one year old pa_jack.c file.
This file is dated 14 March 2005 in owm pa-v19 CVS tree.

======= On Friday 08 July 2005 00:49, Kevin Cosgrove wrote: =======

On 2 July 2005 at 18:15, Eric Robert <roberteric at neuf.fr> wrote:

> Has anyone used audacity with jack successfully?


Off list Eric and I exchanged the following.  It seems the problem is 
resolved, and I wanted to make sure that the info gets to this list 
and to this list's archive.


Kevin Cosgrove wrote:
> Do you know about this?  I found this on the net.  I haven't tried it 
> yet, nor have I tried your suggestions....
> 
> ------- Forwarded Message
> 
> 
> [a-users] [Audacity+jack] Good news. "I was able to run Hydrogen drum machine 
> through jack and have audacity record the audio! " 
> SMITH Linton Linton.SMITH at Tenix.com 
> Fri May 20 02:29:07 CEST 2005 
> 
> Previous message: [a-users] demudi 1.2.1 rc2 observations from a new user 
> 
> Next message: [a-users] demudi 1.2.1 rc2 observations from a new user 
> 
> Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] 
> 
> More things........
> 
> ^^^^^^^^^^^^
> 
> De: "SMITH Linton" <Linton.SMITH at Tenix.com>
> Para: audacity-users at lists.sourceforge.net
> Fecha: 20/05/05 05:10
> 
> Marcos,
> 
> Good news.  I tried the latest pa_snapshot-v19. I was able to run Hydrogen
>  drum machine through jack and have audacity record the audio! So things have
>  improved.  I had to define 2 pre-processor macros to substitute for 2 Jack
>  size functions as my Jack library is not upto date. But it did work.
> 
> To make it work:
> 
> 1. download the latest pa_snapshot_v19 from the PortAudio website.
> 2. Unpack this into Audacity-1.2.3/lib-src/
> 3. Delete the old portaudio-v19 directory
> 3. Rename the portaudio directory portaudio-v19
> 4. configure audacity to build with portaudio-v19
> 	./configure --enable-portaudio=v19
> 5. build audacity
> 	make
> 6. optionally install audacity
> 7. Start the jack daemon
> 	jackd -d alsa
> 8. Start your jack enabled sound sources
> 	hydrogen
> 	rosegarden
> 	timidity -B2,8 -iA -Oj
> 
> 9. Start a jack patch app
> 	jack-patch-bay
> 
> or
> 	qjackctl
> 
> 10. Ensure all jack apps have created their jack client ports.
>       Timidity requires a midi input to be connected before it
>  creates it's jack output port!
> 
> 11. Once you have all of your Jack apps running with output ports, start
>  audacity (portaudio-v19 enabled) Note: if you start it from the command line
>  you will see error messages regarding access to the alsa devices
> 
> 12. Open the preferences Audio I/O dialog.  You will now be able to select
>  the available jack clients as your recording source.
> 
> 	Note: if you start up more jack clients, they are not detected 
>	by audacity.
>  You must exit audacity and restart it to detect the new jack clients. :(
>  Furthermore, Audacity does not open a jack input port until you hit record
>  or play.  When it does it automatically connects them with the selected
>  input or output jack client. BUT it closes the ports when playback/record is
>  stopped.
> 
> 	MATT/VAUGHAN/DOMENIC: This is not how jack access should 
>  work. ports should not go away unless the client(eg audacity)
>  is shutdown. The idea is to create them, connect them, then
>  use them. this is may or may not be a portaudio problem.  I
>  have not looked into Audacity's use of PA and PA_JAck to
>  determine where the fault is but it is possible that it is
>  in EITHER audacity's use of PA or PA's use of Jack. We would
>  greatly appreciate it if you would take a look and see IF
>  your use of PA needs to be modified to ensure jack client
>  longevity.  I will inform the PA crowd of this as well so that
>  they can check their side of things, if I get a chance.
> 
> 	MARCOS: Hope this helps.
> 
> Hasta luego
> 
> Linton
> 
> 
> 
> 
> Previous message: [a-users] demudi 1.2.1 rc2 observations from a new user 
> 
> Next message: [a-users] demudi 1.2.1 rc2 observations from a new user 
> 
> Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] 
> 
> More information about the Users mailing list
> 
> ------- End of Forwarded Message


 
All right!
Everything works very well now!
commented [out] all the patches BUT the audacity-1.2.2-wxheaders.patch.bz2
Thanks!

Eric

 
--
Kevin




More information about the linux-audio-user mailing list