[linux-audio-user] jack xruns on SUSE 9.3 with Edirol UA25 card - SOLVED

Lee Revell rlrevell at joe-job.com
Thu Jul 28 16:57:04 EDT 2005


On Thu, 2005-07-28 at 10:11 -0500, Ryan wrote:
> On Thu, 2005-07-28 at 15:26 -0400, Lee Revell wrote:
> > On Thu, 2005-07-28 at 02:59 -0500, Ryan wrote:
> > > On Thu, 2005-07-28 at 08:07 +0200, Cesare Marilungo wrote:
> > > > I solved the problem *cough* disabling the ethernet card. Don't know why
> > > > it worked randomly yesterday.
> > > 
> > > I can confirm this problem/solution.  UA25 glitchy as heck till eth0 is
> > > disabled.  I have a dell inspiron 5100 running gentoo btw.
> > > 
> > > Makes icecast streaming jackd a bit tough, but at least it works.
> > 
> > Are you both using the same network driver/hardware?  Does it share an
> > interrupt with the USB?
> 
> Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
> Interrupt: pin A routed to IRQ 7
> 
> (b44 module, marked experimental since 2.4.x days)
> 

Since the interrupt is not shared, you should really not be having this
problem.  The b44 module is likely to be the cause.  It may be disabling
interrupts globally.

Try running Ingo's RT preempt kernel with all latency/irqs off
debugging enabled.

> USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
> USB UHCI Controller
> Interrupt: pin [A, B, C, d] routed to IRQ 11
> 
> This is an UHCI controller... I thought the usb kernel stuff was going
> to get some attention, something about top-half/bottom-half irq
> handling?  Afaik that hasn't happened yet.

2.6.13 should be better.

Lee



More information about the linux-audio-user mailing list