[linux-audio-user] Latency problems with MAudio 24/96

Them idragosani at chapelperilous.net
Wed Mar 9 08:11:52 EST 2005


Bill Allen<lau at ballen.fastmail.fm> wrote:
> I'm having really bad xrun problems in jack with my MAudio 24/96 card. I 
> can't find any setting that doesn't result in 10's of xruns every few 
> minutes which is obviously unacceptable. The latency doc in the linux 
> audio users page at 
> http://www.djcj.org/LAU/guide/Low_latency-Mini-HOWTO.php3 points out that 
> most soundcards want to have an IRQ of 9, 10 or 11. When I cat 
> /proc/interrupts (below), it appears that my card is at IRQ 19 which as I 
> understand it puts it behind just about everything. Could that 
> be the root of my xrun problem? If so, how can I make the card be on 
> another interrupt.
> 
> Regards,
> Bill
> 
> cat /proc/interrupts
>            CPU0
>   0:     738208    IO-APIC-edge  timer
>   1:        379    IO-APIC-edge  i8042
>   2:          0          XT-PIC  cascade
>   8:          0    IO-APIC-edge  rtc
>   9:          0   IO-APIC-level  acpi
>  12:      24226    IO-APIC-edge  i8042
>  14:      71993    IO-APIC-edge  ide2
>  15:      20598    IO-APIC-edge  ide3
>  16:      43548   IO-APIC-level  ohci1394, nvidia
>  17:       2157   IO-APIC-level  SysKonnect SK-98xx
>  18:          0   IO-APIC-level  libata
>  19:        177   IO-APIC-level  ICE1712
>  21:          0   IO-APIC-level  uhci_hcd, uhci_hcd, uhci_hcd, uhci_hcd, 
> ehci_hcd

That wouldn't cause xruns, AFAIK.

What else do you have running on this machine. in terms of btoh software 
and hardware?

What kernel are you using?  Does it support low latency/realtime (either 
a patched 2.4 kernel or a newer 2.6 kernel)?

How are you starting jack?

-- Brett


More information about the linux-audio-user mailing list