[linux-audio-user] Suse 9.2

Martin Wohlleben Martin.Wohlleben at gmx.de
Thu May 19 13:40:09 EDT 2005


Am Donnerstag, 19. Mai 2005 06:19 schrieb Larry Troxler:
> Hi, I recently experienced the Great Hard Disk Crash of 2005, and am
> starting again with Suse 9.2.
>
> I see it has most of the great audio apps included, but of course some of
> these apps are probably out of date.
>
> My immediate problem seems to be that MIDI isn't working; If I run the test
> MIDI patch in pd, for example, nothing happens with either MIDI input or
> output, using the MIDI port on my Soundblaster PCI 512 card.
>
> Also, when running rosegarden, I hear nothing when I press the test tone
> button on the GUI for the fluidsynth DSSI.
>
> I do see that the /dev/midi* devices are there.
>
> I haven't yet updated the kernel or installed the realtime_lsm module,
> although I suppose this should have nothing to do with whether MIDI works.
>
> For the time being, I'm starting jackd as root, and running rosegarden and
> pd as root, using sux.
>
> If someone can suggest a place to start troubleshooting, it would be most
> helpfull.
>
> Thanks in advance!
>
> Larry Troxler

Hi Larry,

I also use SuSE 9.2 as basic system with an RME Multiface. I did many changes 
(realtime lsm, new jackd, alsa 1.09 rc, ...) for better latencies but midi 
worked always fine. 
You can install the SuSE packages KAconnect to connect the alsa-midi ports 
with applications (nice GUI) or QMidiArp to check if there are midi events. 
Rosegarden doesn't provide an alsa midi port. It has its own midi 
implementation, the SuSE package didn't work really good but after compiling 
from source it works fine too. The problem with /dev/midi is maybe that you 
use just alsa and no oss emulation. 

good luck
Martin


More information about the linux-audio-user mailing list