[linux-audio-user] kfusd module (oss2jack) unknown symbols with 2.6.13

Salvatore Di Pietro salvuz_78 at virgilio.it
Fri Sep 16 15:49:55 EDT 2005


Esben Stien wrote:
 > Salvatore Di Pietro <salvuz_78 at virgilio.it> writes:
 >
 >
 >>It really depends on the application.
 >
 >
 > Yes, I know, but none of the mentioned apps do voip;). At least not
 > free ones. Playback only apps works fine.

I tried Gnomemeeting as well, but no luck with jacklaunch or oss2jack... :(

 > I've tested with: asterisk, mplayer, audacity, ecasound and sox.

I use with success:

Gnome Wave Cleaner
Avidemux2
ReZound (playback only)
Skype
sox
GNUsound (native JACK supports segfaults)
^^^^^^^^
     '- this one works with inputs, (only at JACK samplerate)
     if you play with OSS preferences in the program

ZynAddSubFX (it gives me rock solid performance even upon loading a
PADsynt instrument) (see link below)


 >
 >>I dind't manage to make it work with Audacity, though...
 >
 >
 > Right, I get "Error while opening sound device" no matter what rates
 > and depths I set it to.

Me too, I'll try without loading alsa-oss modules (to give a /dev/dsp 
wired with oss2jack), to see if at least doesn't give that error...

 > With sox and ecasound, it has to be suspended and then killed. The
 > file produced are either full of errors (ecasound) or empty (sox).
 >
 > I'd really like to find out why audacity don't work since it's
 > mentioned to work. It might be related to the patch and
 > linux-2.6.13.

I'm using oss2jack since 2.6.10, before the patch to fusd-kor and before 
oss2jack supported audio input at all, and Audacity never worked for 
me... :(

BTW, have you experienced the Jack crackling problem I described here?

http://music.columbia.edu/pipermail/linux-audio-user/2005-August/025787.html

I'm gonna buy an M-Audio Delta44 now, and I would be happy if that 
occasional crackling wouldn't happen anymore...

ciao
-- 
           salvuz
      POST FATA RESVRGO
  Linux registered user #291700 | machine #174619
  get counted on ---> http://counter.li.org/ <---


More information about the linux-audio-user mailing list