[linux-audio-user] ecasound question with RME hammerfall lite.

Stephen Cameron smcameron at yahoo.com
Wed Dec 6 23:26:11 EST 2006


Well, I sorted out the routing problems within my AW4416,
so now I can record multiple tracks from the AW4416 to the
PC via ecasound and JACK, but, still having a bit of trouble.

My procedure so far is:

# start ecasound, as for example:

(as root)
ecasound -c -r -b:128 -a:1,2 -i jack -o drums.wav -a:3,4 -i jack -o guitar.wav

(JACK is also running as root)

* Type "engine-launch" in ecasound.

* In qjackctl, on the connections screen, connect the hammerfall's 
capture channels (corresponding to AW4416 busses) to ecasound's 
inputs.

* Type "start" in ecasound, and start playback on the AW4416.

This works, but it seems small sections of the audio are 
being dropped here and there, so the result is that the 
transferred data is mostly correct, but is kind of "jumpy"
as it skips these apparently dropped sections, which are
short, but definitely noticeable.  I suppose it could be
some issue with my OS, scheduling, etc., or possibly
cable problems.  That latter I can rule out by moving
my computer, and using different, shorter cables, I guess.
(Haven't done that yet.)

-- steve

--- Stephen Cameron <smcameron at yahoo.com> wrote:

> 
> I'm trying to record multiple tracks at once from my RME Hammerfall lite,
> just to transfer from my AW4416 to PC, the stereo tracks are already recorded
> on the AW4416, I just want to transfer them both at once.
> 
> Is this the right way to do it?
> 
> ecasound -r -c -a:1,2 -i jack -o guitar.wav -a:3,4 -i jack -o drums.wav
> 
> Then, type "engine-launch" to ecasound,
> 
> then (via qjackctl) connect RME capture channels 1-4 to ecasound inputs 1-4
> (assuming audio is coming in on channels 1-4).
> 
> Then type "start" in ecasound, and start playback on the aw4416.
> 
> So far by this method, I'm capturing only silence, but I suspect 
> this is a mistake I'm making on the AW4416 with routing audio to 
> the ADAT outputs.
> 
> Just want to make sure I'm using ecasound in the correct way
> to accomplish what I'm trying to do.
> 
> -- steve
> 
> 
> 
>  
> ____________________________________________________________________________________
> Do you Yahoo!?
> Everyone is raving about the all-new Yahoo! Mail beta.
> http://new.mail.yahoo.com
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


More information about the linux-audio-user mailing list