[linux-audio-user] CCRMA and yum

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Thu Feb 16 18:50:26 EST 2006


On Wed, 2006-02-15 at 14:04 -0800, thewade wrote:
> Quoting Fernando Lopez-Lezcano <nando at ccrma.Stanford.EDU>:
> > On Wed, 2006-02-15 at 11:55 -0800, thewade wrote:
> >> Quoting Fernando Lopez-Lezcano <nando at ccrma.Stanford.EDU>:
> >> > On Tue, 2006-02-14 at 19:39 -0800, thewade wrote:
> >> >> I am encountering some problems though. Probably descrepancies between
> >> >> the livna repository and the ccrma repository. Can you tell me if I am
> >> >> correct?
> >> >>
> >> >> yum -y update
> >> >> [lots of messages here...]
> >> >> Error: Missing Dependency: libavcodec.so.51 is needed by package xine-lib
> >> >> Error: Missing Dependency: faad2 = 0:2.0-0.lvn.5.4 is needed by package
> >> >> xmms-faad2
> >> >>
> >> >> And it ends there. Just to see if it was missing some file I built from
> >> >> source I ran:
> >> >> rpm -qa | grep faad
> >> >> xmms-faad2-2.0-0.lvn.5.4
> >> >> faad2-2.0-0.lvn.5.4
> >> >> rpm -qla | grep libavcodec
> >> >> /usr/lib/libavcodec-CVS.so
> >> >> /usr/lib/libavcodec.so
> >> >> /usr/lib/libavcodec.so.51
> >> >> [MUNCH]
> >>
> >> I do have some of thoes packages installed:
> >>   rpm -q mjpegtools ffmpeg kino ffmpeg2theora
> >>   mjpegtools-1.8.0-0.lvn.1.4
> >>   ffmpeg-0.4.9-0.lvn.0.20.20051228.4
> >>   kino-0.7.6-0.lvn.3.4
> >>   package ffmpeg2theora is not installed
> >>
> >> I tried to upgrade just these packages but it comes back to
> >> libavcodec.so.51 for xine-lib
> >>   rpm -q xine-lib
> >>   xine-lib-1.1.1-0.lvn.3.4
> >>
> >> What version of xine-lib is in ccrma?
> >
> > Planet CCRMA does not have it.
> >
> >> Or perhaps your repository has a newer ffmpeg then livna, and the solution
> >> is for livna to update their xine-lib with the new ffmpeg?
> >
> > Nope, according to your package list livna's version of ffmpeg is newer
> > than Planet CCRMA's.
> 
> OK, I get it now. the Livna ffmpeg is 0.4.9-0 and ccrma is 0.4.9-0.1 
> but the date is newer for the livna version. Where they put the "lvn" 
> confused me as to the version. (but then again I am an idiot. It 
> doesn't take much to confuse me.)
> 
> >> The guy that runs livna is pritty nice
> >> and perhaps he would do that, if that is the problem...
> >> I still do not understand where the breakdown is happening though. Your
> >> version of libavcodec (from ffmpeg) is newer then the livna libavcodec,
> >> and so xine-lib should be happy, right?
> >
> > No, I don't think livna's is older. Xine-lib wants a specific version of
> > libavcodec, and it is not compatible with the one in Planet CCRMA.
> >
> > I still don't understand completely. Do you have xine-lib installed
> > already?
> 
> I have the livna xine-lib installed (so I can watch DVD's using xine):
> xine-lib-1.1.1-0.lvn.3.4
> 
> 
> > Or is that what is triggering the problem when you try to
> > install it?
> 
> That is where I am confused. I just run "yum update" and it dies on 
> libavcodec and faad2.

I'm confused as well. I'm not used to yum so I don't really know how to
troubleshoot this. I can't make up my mind on which side is breaking
things. 

Try removing the Planet CCRMA urls from the yum configuration file, and
then doing a "yum update". 

-- Fernando




More information about the linux-audio-user mailing list