[linux-audio-user] ecasound interactive mode

Paul Coccoli pcoccoli at gmail.com
Mon May 22 22:34:52 EDT 2006


How do you add a second chain in ecasound in interactive mode?  I can
create one chain that reads a file for input and outputs to jack, but
if I try to add another chain I get the following:

ecasound ('h' for help)> c-add t2
(eca-control) WARNING: This operation requires that chainsetup is
... disconnected. Temporarily disconnecting...
- [ Engine exiting ] -----------------------------------------------------------
(eca-control-objects) Disconnecting chainsetup: "command-line-setup".
- [ Chainsetup disconnected ] --------------------------------------------------
(eca-control-objects) Added chains: t2.
(eca-chainsetup) Unable to connect: Chain "t2" is not valid. Following errors
... were detected:
(eca-chainsetup) Chain "t2" is not connected to any input. All chains must have
... exactly one valid input. (2.1-NO-CHAIN-INPUT)
(eca-chainsetup) Chain "t2" is not connected to any output. All chains
must have
... exactly one valid output. (2.2-NO-CHAIN-OUTPUT)
ERROR: Can't reconnect chainsetup.

Well, ok, so then I quit, restart with 1 chain again, THEN create new
input and output, and try to create a second chain:

ecasound ('h' for help)> ai-add jack_auto
(eca-control-objects) Added audio input "jack_auto".
ecasound ('h' for help)> ao-add jack_auto
(eca-control-objects) Added audio output "jack_auto".
ecasound ('h' for help)> c-add t2
(eca-control-objects) Added chains: t2.
ecasound ('h' for help)> c-list
t1,t2
ecasound ('h' for help)> start
(eca-chainsetup) Unable to connect: Chain "t2" is not valid. Following errors
... were detected:
(eca-chainsetup) Chain "t2" is not connected to any input. All chains must have
... exactly one valid input. (2.1-NO-CHAIN-INPUT)
(eca-chainsetup) Chain "t2" is not connected to any output. All chains
must have
... exactly one valid output. (2.2-NO-CHAIN-OUTPUT)
(eca-chainsetup) WARNING: Input "track1.wav" is not connected to any chain.
... (3.1-DISCON-INPUT)
(eca-chainsetup) WARNING: Output "jack_auto" is not connected to any chain.
... (3.2-DISCON-OUTPUT)
ERROR: Selected chainsetup cannot be connected. Can't perform requested action.

Hmm.  If a chain MUST have one valid input and output, but inputs and
outputs need to be connected to a chain, THEN ITS A PARADOX AND MY
HEAD EXPLODES!

Seriously, I'm tryin the most basic thing in the world and I can't do
it.  Maybe it's just too late at night...

paul


More information about the linux-audio-user mailing list