[linux-audio-user] Were's the weak link?

Mike Taht mike.taht at gmail.com
Sat Jan 20 17:56:41 EST 2007


On 1/20/07, linuxmedia4 at netscape.net <linuxmedia4 at netscape.net> wrote:
>
> >> Can anyone spot where the "weak link" is in my system. I put in this
> >> post (what I believe) is the most relevant information...


Is cpuspeed running? If so, disable it.

Also I note that ingo is keeping a repository of the latest rt kernels (he's
at 2.6.20 something at present) at:

http://people.redhat.com/mingo/realtime-preempt/yum.README

This series has been pretty good for me, but YMMV

>>
> >> My system...
> >> Dell Precision M50 laptop
> >> 2 GHz Processor
> >> 1 Gig Ram
> >> 2.6.16-1.2080.16.rrt.rhfc5.ccrma
> >> 7200rpm hard drive
> >>
> >> 'cat /proc/interrupts' (before disabling peripherals) shows:
> >> 11:    8900  XT-PIC [........./  0]  yenta, yenta, yenta,
> >> pcmcia2.0, Indigo IO, uhci_hcd:usb1, uhci_hcd:usb2, ohci1394
>
> > What does IRQ 11 look like when the unused drivers are unloaded?
>
> Actually, I never went back to (en)abling the peripherals in BIOS. I'll
> wait untill I finally find the culprit and then enable them and see what
> happens. So this reflects my current situation...
>
>    0: 555937  XT-PIC [........N/  0]  pit
>    1:   1344  XT-PIC [........./  1]  i8042
>    2:      0  XT-PIC [........N/  0]  cascade
>    7:      0  XT-PIC [........./  0]  Intel 82801CA-ICH3, Intel
> 82801CA-ICH3 Modem
>    8:      1  XT-PIC [........./  0]  rtc
>    9:      0  XT-PIC [........./  0]  acpi
>   11:   7038  XT-PIC [........./  0]  yenta, yenta, Indigo IO,
> uhci_hcd:usb1, uhci_hcd:usb2, ohci1394, eth0
>   12:  24456  XT-PIC [........./  0]  i8042
>   14:  14998  XT-PIC [........./  0]  ide0
> NMI:      0
> LOC:      0
> ERR:      0
> MIS:      0
>
> > Did you run the rtirq script?
>
> During bootup, I see mentions of S88rtirq, so I looked and I see there
> is '/etc/rc.d/rc3.d/S88rtirq'.
>
> > Does JACK report xruns when these glitches happen?
>
> While recording with ecasound (with realtime privileges) and running
> 'jackd -v -R -dalsa -r48000 -p512 -n2 -D -Chw:2 -Phw:2'... during the
> interruptions, I received these messages...
>
> (I get interruptions with every combination of periods and buffer sizes
> I've tried)
>
> delay of 42746.000 usecs exceeds estimated spare time of 9632.000;
> restart ...
> delay of 42669.000 usecs exceeds estimated spare time of 9625.000;
> restart ...
> delay of 42647.000 usecs exceeds estimated spare time of 9608.000;
> restart ...
> delay of 42646.000 usecs exceeds estimated spare time of 9700.000;
> restart ...
> delay of 42600.000 usecs exceeds estimated spare time of 9741.000;
> restart ...
>
> Thanks... keep the suggestions coming. I'm not going to settle for this
> as the result after investing 5 years into Linux/Audio.
>
> Rocco
>
>


-- 
Mike Taht
PostCards From the Bleeding Edge
http://the-edge.blogspot.com
"Have you noticed that the earth is tipped away from the sun at the moment?
Really sloppy quality control. I filed a request to have it tipped towards
the sun again, but you know how these things go. Probably take 'em 6 months
to fix it" - E.H.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://music.columbia.edu/pipermail/linux-audio-user/attachments/20070120/5a27a172/attachment.html


More information about the linux-audio-user mailing list