[linux-audio-user] guitar amp emulation

Yves Potin yves at jazzcomputer.org
Tue Mar 6 16:40:29 EST 2007


Le 06 Mar à 15:51, Paul Davis ecrivait:

> what same XWindow problem?


        This one : 

The program 'fst' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 55944 error_code 189 request_code 155 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)


        It occurs randomly after a short use of the GUI of *any* VST I
have used so far. The same VSTs can be used for hours without any problem
with jack-dssi-host. I'm sure that many other people encounter this
problem, for example this guy : 
http://bugs.winehq.org/show_bug.cgi?id=6673
        I have already described this problem in an e mail here : Date:
Fri, 1 Dec 2006 12:37:27 and I had no answer. I have talked about this two
times on #ardour and there was immediately someone to report the same
problem. 


> these plugins have no GUI - the host has to build one. FST doesn't do
> that. Ardour does, and I thought that JACK-DSSI did  or could as well.

        Thanks for this precision and for the other answers.
        Best, 

Y.


More information about the linux-audio-user mailing list