[linux-audio-user] Qsynth multi audio channel config problem

ciwe at gmx.de ciwe at gmx.de
Wed Mar 21 09:31:32 EDT 2007


Hello everybody,

I've tried to set up qsynth with multiple audio output channels for each 
midi channel. Is it possible?
Below is the ~/.qt/qsynthrc file of my tests where I set multi jack 
outputs to true, 16 audio channels and one audio group (tried also 16 
audio groups).

So what I'm doing wrong?

Thanks for your help

Regards

	Chris


/ - - - - - Snip 

[Defaults]
PresetPreview=true
SoundFontDir=/home/chris/music/Sounds

[Geometry]
qsynthChannelsForm/height=207
qsynthChannelsForm/visible=false
qsynthChannelsForm/width=778
qsynthChannelsForm/x=238
qsynthChannelsForm/y=0
qsynthMainForm/height=191
qsynthMainForm/visible=true
qsynthMainForm/width=830
qsynthMainForm/x=122
qsynthMainForm/y=388
qsynthMessagesForm/height=112
qsynthMessagesForm/visible=false
qsynthMessagesForm/width=328
qsynthMessagesForm/x=0
qsynthMessagesForm/y=347

[Options]
KeepOnTop=true
MessagesFont=Fixed,10,-1,0,50,0,0,0,0,0
MessagesLimit=true
MessagesLimitLines=1000
OutputMeters=true
QueryClose=true
StdoutCapture=true
SystemTray=false

[Preset]
Chan1=0:0:0
Chan10=9:128:0

[Presets]
DefPreset=(default)

[Program]
Version=0.2.5

[Settings]
AlsaName=Test16a
AudioBufCount=2
AudioBufSize=64
AudioChannels=16
AudioDevice=
AudioDriver=jack
; Also 16 for the groups did not work 
AudioGroups=1
ChorusActive=false
ChorusDepth=8
ChorusLevel=2
ChorusNr=3
ChorusSpeed=0.3
ChorusType=0
DisplayName=Test16d
Gain=0.2
JackAutoConnect=true
JackMulti=true
JackName=Test16j
LadspaActive=false
MidiChannels=16
MidiDevice=
MidiDriver=alsa_seq
MidiDump=false
MidiIn=true
Polyphony=256
ReverbActive=false
ReverbDamp=0
ReverbLevel=1
ReverbRoom=0.2
ReverbWidth=0.5
SampleFormat=16bits
SampleRate=44100
Server=false
Verbose=false

[SoundFonts]
BankOffset1=0
SoundFont1=/home/chris/music/Sounds/FluidR3 GM.SF2


More information about the linux-audio-user mailing list