[Portaudio] Host Api change from paInDevelopment to paASIO

Guruswamy B M guruswamy.1984 at gmail.com
Fri Mar 9 08:27:35 EST 2012


Hi Ross,
Thanks for the reply.
I am using the latest portaudio (ver 19)

I am able to play a audio now. Problem is with Portaudio.dll, where I
didn't enabled the preprocessor as PA_US_ASIO = 1;

Now my next task is to play a multiple audio files at a time. (EX:
audio 1 in Octa capture ports (5,6) and audio 2 in Octa capture ports
(3,4)).  Do you have any idea how to do this?

Thanks and Regards,
Guruswamy B M

On 3/8/12, Ross Bencina <rossb-lists at audiomulch.com> wrote:
> Hi Guru,
>
> The type id should not be 0. Ever. Sometimes the confusion is in
> retrieving a hostApiIndex (if ASIO is the only host API it will have
> index zero), but your code below does look like it is correctly
> retrieving the type.
>
> Can you confirm that the type field has value 0?
>
> Pa_GetHostApiInfo(deviceInfo->hostApi)->type
>
> Please say which version of PortAudio you're using.
>
> Thank you,
>
> Ross.
>
>
>
> On 8/03/2012 10:38 PM, Guruswamy B M wrote:
>> Hi All,
>> I am using port audio to play a file in octa capture through ASIO. In
>> doing this I am able to get all device information, but host API
>> selected as '0' ( enum value in PaHostApiTypeId) instead of 3.
>>
>> So how to change Host API from 0 to 3. Because of this problem I am not
>> able to load the device info into 'GLOBAL_asioDeviceInfo', since
>> statement in "if (Pa_GetHostApiInfo(deviceInfo->hostApi)->type ==
>> paASIO)" is failing in 'queryDevices' function.
>>
>> Any help in this issue greatly appreciated
>>
>> Thanks and Regards,
>> Guru
>> '
>>
>>
>> _______________________________________________
>> Portaudio mailing list
>> Portaudio at music.columbia.edu
>> http://music.columbia.edu/mailman/listinfo/portaudio
> _______________________________________________
> Portaudio mailing list
> Portaudio at music.columbia.edu
> http://music.columbia.edu/mailman/listinfo/portaudio
>


More information about the Portaudio mailing list